BGP configuration example - RouterOS Mikrotik

Please change the data to your own:

185.37.8.1 - client's router ipv4 address
185.37.8.0/24 - client's ipv4 net
2a10:c947::/32 - client's ipv6 net
206447 - client's ASn 
5.101.92.180 - client's ipv4 address in LL-IX
2001:678:4fc::92:180 - client's ipv4 address in LL-IX

 

Configuration example:

/routing bgp instance
set default as=206447 redistribute-connected=yes router-id=185.37.8.1
/interface bridge
add name=bridge1 protocol-mode=none
/ip address
add address=5.101.92.180/22 interface=ether2
add address=185.37.8.1/24 interface=bridge1
/ipv6 address
add address=2001:678:4fc::92:180/48 advertise=no interface=ether2
add address=2a10:c947::1/32 advertise=no interface=bridge1
/routing bgp network
add network=185.37.8.0/24 synchronize=no
add network=2a10:c947::/32 synchronize=no
/routing bgp peer
add in-filter=LL-IX_bgp4_in max-prefix-limit=500000 name=LL-IX_RS1_v4 out-filter=LL-IX_bgp4_out remote-address=5.101.92.9 remote-as=59947 ttl=default update-source=ether2
add in-filter=LL-IX_bgp4_in max-prefix-limit=500000 name=LL-IX_RS2_v4 out-filter=LL-IX_bgp4_out remote-address=5.101.92.2 remote-as=59947 ttl=default update-source=ether2
add address-families=ipv6 in-filter=LL-IX_bgp6_in max-prefix-limit=100000 name=LL-IX_RS1_v6 out-filter=LL-IX_bgp6_out remote-address=2001:678:4fc::9 remote-as=59947 ttl=default update-source=ether2
add address-families=ipv6 in-filter=LL-IX_bgp6_in max-prefix-limit=100000 name=LL-IX_RS2_v6 out-filter=LL-IX_bgp6_out remote-address=2001:678:4fc::2 remote-as=59947 ttl=default update-source=ether2
/routing filter
add action=discard chain=LL-IX_bgp4_out prefix=10.0.0.0/8 prefix-length=8-32
add action=discard chain=LL-IX_bgp4_out prefix=192.168.0.0/16 prefix-length=16-32
add action=discard chain=LL-IX_bgp4_out prefix=172.16.0.0/12 prefix-length=12-32
add action=discard chain=LL-IX_bgp4_out prefix=169.254.0.0/16 prefix-length=16-32
add action=discard chain=LL-IX_bgp4_out prefix=224.0.0.0/4 prefix-length=4-32
add action=discard chain=LL-IX_bgp4_out prefix=240.0.0.0/4 prefix-length=4-32
add action=accept chain=LL-IX_bgp4_out comment="my own ipv4 prefix" prefix=185.37.8.0/24
add action=discard chain=LL-IX_bgp4_out
add action=discard chain=LL-IX_bgp4_in prefix=10.0.0.0/8 prefix-length=8-32
add action=discard chain=LL-IX_bgp4_in prefix=192.168.0.0/16 prefix-length=16-32
add action=discard chain=LL-IX_bgp4_in prefix=172.16.0.0/12 prefix-length=12-32
add action=discard chain=LL-IX_bgp4_in prefix=169.254.0.0/16 prefix-length=16-32
add action=discard chain=LL-IX_bgp4_in prefix=224.0.0.0/4 prefix-length=4-32
add action=discard chain=LL-IX_bgp4_in prefix=240.0.0.0/4 prefix-length=4-32
add action=accept chain=LL-IX_bgp4_in
add action=discard chain=LL-IX_bgp6_out prefix=::/96 prefix-length=96-128
add action=discard chain=LL-IX_bgp6_out prefix=::/128 prefix-length=128
add action=discard chain=LL-IX_bgp6_out prefix=::1/128 prefix-length=128
add action=discard chain=LL-IX_bgp6_out prefix=::ffff:0.0.0.0/96 prefix-length=96-128
add action=discard chain=LL-IX_bgp6_out prefix=::224.0.0.0/100 prefix-length=100-128
add action=discard chain=LL-IX_bgp6_out prefix=::127.0.0.0/104 prefix-length=104-128
add action=discard chain=LL-IX_bgp6_out prefix=::/104 prefix-length=104-128
add action=discard chain=LL-IX_bgp6_out prefix=::255.0.0.0/104 prefix-length=104-128
add action=discard chain=LL-IX_bgp6_out prefix=::/8 prefix-length=8-128
add action=discard chain=LL-IX_bgp6_out prefix=200::/7 prefix-length=7-128
add action=discard chain=LL-IX_bgp6_out prefix=3ffe::/16 prefix-length=16-128
add action=discard chain=LL-IX_bgp6_out prefix=2001:db8::/32 prefix-length=32-128
add action=discard chain=LL-IX_bgp6_out prefix=2002:e000::/20 prefix-length=20-128
add action=discard chain=LL-IX_bgp6_out prefix=2002:7f00::/24 prefix-length=24-128
add action=discard chain=LL-IX_bgp6_out prefix=2002::/24 prefix-length=24-128
add action=discard chain=LL-IX_bgp6_out prefix=2002:ff00::/24 prefix-length=24-128
add action=discard chain=LL-IX_bgp6_out prefix=2002:a00::/24 prefix-length=24-128
add action=discard chain=LL-IX_bgp6_out prefix=2002:ac10::/28 prefix-length=28-128
add action=discard chain=LL-IX_bgp6_out prefix=2002:c0a8::/32 prefix-length=32-128
add action=discard chain=LL-IX_bgp6_out prefix=fc00::/7 prefix-length=7-128
add action=discard chain=LL-IX_bgp6_out prefix=fe80::/10 prefix-length=10-128
add action=discard chain=LL-IX_bgp6_out prefix=fec0::/10 prefix-length=10-128
add action=discard chain=LL-IX_bgp6_out prefix=ff00::/8 prefix-length=8-128
add action=accept chain=LL-IX_bgp6_out comment="my own ipv6 prefix" prefix=2a10:c947::/32
add action=discard chain=LL-IX_bgp6_out
add action=discard chain=LL-IX_bgp6_in prefix=::/96 prefix-length=96-128
add action=discard chain=LL-IX_bgp6_in prefix=::/128 prefix-length=128
add action=discard chain=LL-IX_bgp6_in prefix=::1/128 prefix-length=128
add action=discard chain=LL-IX_bgp6_in prefix=::ffff:0.0.0.0/96 prefix-length=96-128
add action=discard chain=LL-IX_bgp6_in prefix=::224.0.0.0/100 prefix-length=100-128
add action=discard chain=LL-IX_bgp6_in prefix=::127.0.0.0/104 prefix-length=104-128
add action=discard chain=LL-IX_bgp6_in prefix=::/104 prefix-length=104-128
add action=discard chain=LL-IX_bgp6_in prefix=::255.0.0.0/104 prefix-length=104-128
add action=discard chain=LL-IX_bgp6_in prefix=::/8 prefix-length=8-128
add action=discard chain=LL-IX_bgp6_in prefix=200::/7 prefix-length=7-128
add action=discard chain=LL-IX_bgp6_in prefix=3ffe::/16 prefix-length=16-128
add action=discard chain=LL-IX_bgp6_in prefix=2001:db8::/32 prefix-length=32-128
add action=discard chain=LL-IX_bgp6_in prefix=2002:e000::/20 prefix-length=20-128
add action=discard chain=LL-IX_bgp6_in prefix=2002:7f00::/24 prefix-length=24-128
add action=discard chain=LL-IX_bgp6_in prefix=2002::/24 prefix-length=24-128
add action=discard chain=LL-IX_bgp6_in prefix=2002:ff00::/24 prefix-length=24-128
add action=discard chain=LL-IX_bgp6_in prefix=2002:a00::/24 prefix-length=24-128
add action=discard chain=LL-IX_bgp6_in prefix=2002:ac10::/28 prefix-length=28-128
add action=discard chain=LL-IX_bgp6_in prefix=2002:c0a8::/32 prefix-length=32-128
add action=discard chain=LL-IX_bgp6_in prefix=fc00::/7 prefix-length=7-128
add action=discard chain=LL-IX_bgp6_in prefix=fe80::/10 prefix-length=10-128
add action=discard chain=LL-IX_bgp6_in prefix=fec0::/10 prefix-length=10-128
add action=discard chain=LL-IX_bgp6_in prefix=ff00::/8 prefix-length=8-128
add action=accept chain=LL-IX_bgp6_in
  • MikroTik, RouterOS, BGP
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

BGP configuration example - Cisco

Please change the data to your own XXXX - your ASN number 192.168.0/24 and 192.168.1/24 - your...

BGP configuration example - Juniper

Please change the data to your own XXXX - your ASN number 192.168.0/24 and 192.168.1/24 - your...

BGP configuration example - BIRD

Please change the data to your own # 185.37.8.1 - client's router ipv4 address # 185.37.8.0/24...